loading MyMuse | Log In | Register
Search the Knowledge Base - Type your query below:

Currently Supported versions of NI plugins for Komplete 5 bundle

Created: Thu, 01 Apr 2010 12:49:48 -0700; Modified: Thu, 22 Apr 2010 08:17:24 -0700
Keywords: Absynth Akoustik Piano B4 II Battery Elektrik Piano FM8 Guitar Rig 3 Komplete 5 Kontakt 3 Massive Pro53 Reaktor Receptor 2 update
Products: Plug-in (General) RECEPTOR 2 Hardware Receptor

Here are the Native Instruments updates that we have tested and support. Although these may not be the newest versions available, they have been known to run most efficiently and stabily on Receptor. Installing versions that are untested, or unsupported by us can cause severe damage to your hard drive. Additionally, there are special footnotes for Receptor 2 users at the bottom of this article.

  • Absynth 4.0.5
  • Akoustik Piano 1.1.3
  • B4 II 2.0.4
  • Battery 3.0.4
  • FM 8 1.0.3
  • Guitar Rig 3.0*
  • Elektrik Piano 1.5.0.011
  • Kontakt 3.0.2**
  • Kontakt 2.2.4
  • Massive 1.1.3
  • Pro53 3.0.5
  • Reaktor 5.1.5



*Receptor 2 Users can only run Guitar Rig 3 version 3.1.1 at this time.
**Receptor 2 users have the option of Installing the newer Kontakt 3.5 update, howeverlatest Receptor 1.8 update is required.

Muse Research & Development     Muse Research on Facebook     Muse Research on YouTube

© 2004-2017 Muse Research & Development, Inc. All Rights Reserved